Communication error przy próbie odczytu W25N01GV (aler Read ID działa)

Pytania techniczne oraz porady dotyczące programowania pamięci oraz funkcjonalności programatora.
mpk
Posts: 16
Joined: Mon Aug 10, 2020 2:32 pm

Communication error przy próbie odczytu W25N01GV (aler Read ID działa)

Postby mpk » Mon Aug 10, 2020 2:41 pm

Za nic nie mogę się z tą kostką dogadać.
Przylutowana na najprostszym możliwym adapterze, wpięta do ZIFa w programatorze.
Read ID działa ok - zwraca poprawny model, producenta i rozmiar, ale jakakolwiek próba odczytu kończy się "Communication error / Device not found".
Kość po przelutowaniu z powrotem do oryginalnego układu działa ok,
adapter przetestowałem na w25x40 - też ok.

Jak by to można jeszcze ugryźć?

ArT
Posts: 1017
Joined: Wed Mar 25, 2015 8:54 am
Location: Warsaw, Poland
Has thanked: 20 times
Been thanked: 96 times

Re: Communication error przy próbie odczytu W25N01GV (aler Read ID działa)

Postby ArT » Tue Aug 11, 2020 11:14 am

Wygląda mi to na problem zbyt długich połączeń. Pokaż zdjęcie jak masz wpiętą pamięć.

mpk
Posts: 16
Joined: Mon Aug 10, 2020 2:32 pm

Re: Communication error przy próbie odczytu W25N01GV (aler Read ID działa)

Postby mpk » Tue Aug 11, 2020 11:50 am

Raczej żadnych dziwactw.
DSC_0861.JPG
DSC_0861.JPG (1.02 MiB) Viewed 775 times

ArT
Posts: 1017
Joined: Wed Mar 25, 2015 8:54 am
Location: Warsaw, Poland
Has thanked: 20 times
Been thanked: 96 times

Re: Communication error przy próbie odczytu W25N01GV (aler Read ID działa)

Postby ArT » Tue Aug 11, 2020 12:09 pm

Chwila moment, a jaki układ wybierasz w aplikacji? :) Na pewno w srodku jest "N" a nie "Q" albo "B"? Bo W25N01GV nawet nie ma w spisie układów, to jest NAND FLASH a nie NOR FLASH (https://www.winbond.com/resource-files/ ... 032116.pdf). W czym ta pamięć siedzi?

mpk
Posts: 16
Joined: Mon Aug 10, 2020 2:32 pm

Re: Communication error przy próbie odczytu W25N01GV (aler Read ID działa)

Postby mpk » Tue Aug 11, 2020 12:41 pm

Chwila moment, a jaki układ wybierasz w aplikacji?

W25N01GV (załącznik 1)
Na pewno w srodku jest "N" a nie "Q" albo "B"?

Mhm (załącznik 2)
Bo W25N01GV nawet nie ma w spisie układów

eeetam ;) (załącznik 3)

No, NAND, NAND.. nie twierdziłem, że jest inaczej.
Siedzi w xiaomi gateway v3 (aka lumi.gateway.mgl03, aka LM18-MJGWA-V3.0) - ładne zdjęcie płytki na początku i końcu tego wątku
Attachments
2_w25n01gv.JPG
2_w25n01gv.JPG (3.06 MiB) Viewed 773 times
3_revelprog_uklady.png
3_revelprog_uklady.png (76.58 KiB) Viewed 773 times
1_revelprog_chipid.png
1_revelprog_chipid.png (273.13 KiB) Viewed 773 times

ArT
Posts: 1017
Joined: Wed Mar 25, 2015 8:54 am
Location: Warsaw, Poland
Has thanked: 20 times
Been thanked: 96 times

Re: Communication error przy próbie odczytu W25N01GV (aler Read ID działa)

Postby ArT » Tue Aug 11, 2020 1:12 pm

Dobra mam ją - patrzyłem na starszym sofcie a ona ostatnio dodana była. Działa i musi działać i u Ciebie.
ID to samo co u Ciebie, ale jakie masz dalej oznaczenia? Trochę słabo czytelne na zdjęciu
Programator przechodzi test napięć?
Próbowałeś na niższej prędkości? (Ustawienia -> hardware - flash sck). Mi działa na 100% ale może na adapterze są nierównej długości ścieżki co może mieć znaczenie. Spróbuj też na 3.6V.

2020-08-11-13.07.jpg
2020-08-11-13.07.jpg (154.18 KiB) Viewed 771 times

W25N01GV-zapis.jpg
W25N01GV-zapis.jpg (191.08 KiB) Viewed 770 times

mpk
Posts: 16
Joined: Mon Aug 10, 2020 2:32 pm

Re: Communication error przy próbie odczytu W25N01GV (aler Read ID działa)

Postby mpk » Tue Aug 11, 2020 1:30 pm

W25N01GVZEIG / 1949 / 69235T60001

Hardware test cały na zielono.

ArT
Posts: 1017
Joined: Wed Mar 25, 2015 8:54 am
Location: Warsaw, Poland
Has thanked: 20 times
Been thanked: 96 times

Re: Communication error przy próbie odczytu W25N01GV (aler Read ID działa)

Postby ArT » Tue Aug 11, 2020 1:34 pm

Musi działać. Tam edytowałem jeszcze post wyżej nie wiem czy widziałeś (sprawdź na niższej prędkości oraz na wyższym napięciu). Jak nie pójdzie, to sprawdź połaczenia pamięci do programatora czy jest przejście między pinami - moim zdaniem podejrzany będzie adapter.

mpk
Posts: 16
Joined: Mon Aug 10, 2020 2:32 pm

Re: Communication error przy próbie odczytu W25N01GV (aler Read ID działa)

Postby mpk » Tue Aug 11, 2020 1:45 pm

Ani napięcie, ani prędkość nic nie zmienia.
Spróbuję jeszcze po robocie zlutować "na krótko"

mpk
Posts: 16
Joined: Mon Aug 10, 2020 2:32 pm

Re: Communication error przy próbie odczytu W25N01GV (aler Read ID działa)

Postby mpk » Tue Aug 11, 2020 3:53 pm

No i ani na "pajączku" z kynaru, ani na takim adapterze (z plasterkiem kaptonu, żeby pad na spodzie pamięci nie zrobił psikusa) nie udało mi się tego ruszyć.
Identyfikacja chipa w obu przypadkach działa.


Return to “Wsparcie Techniczne”

Who is online

Users browsing this forum: No registered users and 1 guest

cron