Fuel pressure setup and utcomp update issue

Here you can ask technical questions about UTCOMP-3 / UTCOMP-PRO compatibility and features.
douwboy
Posts: 4
Joined: Mon Jul 13, 2020 8:44 am

Fuel pressure setup and utcomp update issue

Postby douwboy » Mon Jul 13, 2020 9:03 am

Hi i recently added a Turbosmart fuel pressure reg and ran a 150PSI Pressure Transducer Sensor 1/8 that i bought off ebay to the utcomp pro. I'm having trouble trying to find and set it all up when i plug it into my laptop. Currently running version 3.3 software i have tried upgrading to the new software but then it tells me the software isn't compatible to the firmware you are running in the UT comp pro please download version 3.3. I have also tried to update the firmware in the UT comp pro using the current software but it won't let me do that either. Am i doing something wrong? I am a bit of a newb when it comes to setting this up any advice would be great thanks. This is the sensor that i'm using off ebay https://www.ebay.com.au/itm/150PSI-Pres ... 2749.l2649 i'm wondering if that is the right one to use as well? Please help.

ArT
Posts: 985
Joined: Wed Mar 25, 2015 8:54 am
Location: Warsaw, Poland
Has thanked: 20 times
Been thanked: 95 times

Re: Fuel pressure setup

Postby ArT » Mon Jul 13, 2020 1:42 pm

To update UTCOMP you need to download latest software and update firmware in device. To to this you will need to click update tab in application and go to update mode (DFU). When UTCOMP switches to DFU mode you may need to install drivers for DFU mode (if windows does not install it automatically - they are in utcomp installation folder). Next you will need to run UTCOMP Loader (from the update tab) and click few times "yes" and it will update firmware to latest version so it will work with latest software.

Fuel pressure sensor - you should connect +5V power and supply to sensor and signal output from sensor to any AdcX input in UTCOMP. Next in settings tab you need to select fuel pressure sensor for AdcX input (where sensor is connected). Next you should active fuel pressure readings on user screen (screen tab)

douwboy
Posts: 4
Joined: Mon Jul 13, 2020 8:44 am

Re: Fuel pressure setup and utcomp update issue

Postby douwboy » Tue Jul 14, 2020 8:31 am

Thankyou for getting back to me so quick. I updated the software in my laptop but i'm having trouble updating the firmware to the controller. The errors i'm getting are "This version of UTCOMP is not compatible with this version of application" And when i try and update the firmware i get this error "The code execution cannot proceed because libusb0.dll was not found. Reinstalling the program may fix this problem" i've tried reinstalling the program and get the same error. Iv'e also found a few files named libusb0.dll in the program folder so i have no idea where to go from here. Can you point me in the right direction?

ArT
Posts: 985
Joined: Wed Mar 25, 2015 8:54 am
Location: Warsaw, Poland
Has thanked: 20 times
Been thanked: 95 times

Re: Fuel pressure setup and utcomp update issue

Postby ArT » Tue Jul 14, 2020 9:04 am

It sometimes happen, there is no any specific solution because it's system issue. You can try to restart utcomp to factory before updating (CTRL + ALT + SHIFT + R). If it not help, please try to update firmware on other PC and when you update, it will work on your current PC too.

douwboy
Posts: 4
Joined: Mon Jul 13, 2020 8:44 am

Re: Fuel pressure setup and utcomp update issue

Postby douwboy » Wed Jul 15, 2020 9:50 am

Thankyou ART for your help did a full restore and that seem to work. I'm so glad i screen shotted all my settings that saved alot of time. One thing i did notice is that the km's till empty changed to hours till empty is there anyway in the settings to change this back?

ArT
Posts: 985
Joined: Wed Mar 25, 2015 8:54 am
Location: Warsaw, Poland
Has thanked: 20 times
Been thanked: 95 times

Re: Fuel pressure setup and utcomp update issue

Postby ArT » Wed Jul 15, 2020 10:04 am

Boat Mode is probably actived (it may happen if you do not restore default settings after update or you import not compatible settings). To disable boat mode without restoring settings to default you need to do in application:
1. go to settings
2. click CTRL + ALT + H (hidden tab #HARDWARE will be displayed)
3. enter "#BOAT" code
4. uncheck boat mode
5 save settings.

douwboy
Posts: 4
Joined: Mon Jul 13, 2020 8:44 am

Re: Fuel pressure setup and utcomp update issue

Postby douwboy » Wed Jul 15, 2020 1:45 pm

Thanks ArT got it all sorted works great. Thanks for your help everything you suggested worked. I even used the calibration data off your pressure sender fact sheet and it worked a treat.


Return to “UTCOMP technical support”

Who is online

Users browsing this forum: No registered users and 2 guests

cron