Communication error [SOLVED]

Here you can ask technical questions about REVELPROG-IS and device/memory programming.
mx12
Posts: 2
Joined: Fri Feb 14, 2020 9:55 am

Communication error [SOLVED]

Postby mx12 » Fri Feb 14, 2020 10:03 am

Hi,
I've updated my Revelprog IS to version 1.8.2, applied firmware update successfully.
Since that, I'm not unable to read/write any chip. The software always report a Communication error.
Here is what I get when I try a blank check:
revelprog.png
revelprog.png (39.45 KiB) Viewed 20 times


I've tried falling back to 1.8.1 (which was working great), but couldn't use it as the firmware was for the new version.

I've tried multiple cables, chip adapters etc, but didn't found anything wrong in my setup.

Please help!
Last edited by mx12 on Fri Feb 14, 2020 4:34 pm, edited 1 time in total.

ArT
Posts: 892
Joined: Wed Mar 25, 2015 8:54 am
Location: Warsaw, Poland
Has thanked: 18 times
Been thanked: 92 times

Re: Communication error

Postby ArT » Fri Feb 14, 2020 11:38 am

I see that you have selected AT25SF161. Nothing has changed in v1.8.2 for this memory so it is not update issue. How about hardware test - does it pass? Anyway, I can send you v1.8.1 so you can downgrade and check it. Please check your PM with details.

mx12
Posts: 2
Joined: Fri Feb 14, 2020 9:55 am

Re: Communication error

Postby mx12 » Fri Feb 14, 2020 4:33 pm

SOLVED: my SO8 adapter was faulty.

To all: don't buy cheap chinese adapters, you'll loose time!


Return to “REVELPROG-IS Technical Support”

Who is online

Users browsing this forum: No registered users and 1 guest