QSFP Page Select is not working - timeout

Here you can ask technical questions about REVELPROG-IS and device/memory programming.
Posts: 1
Joined: Sun Mar 27, 2022 11:31 pm

QSFP Page Select is not working - timeout

Postby llowrey » Tue Mar 29, 2022 8:52 pm

I am able to read from QSFP modules using the A0h (256byte) mode but not when Page Select mode is used. Every time I try to read a page I get "PC TIMEOUT":

Code: Select all

12:22.150: Executing script started.
12:22.153: Setting hardware (I2C 3.2V SLOW)...success
12:22.333: Executing operation 1/2...success
12:22.443: Executing operation 2/2...fail
   2 bytes instr , 128 bytes read , 0 bytes write
   DBO 0 ms , DAI 0 ms , DAW 0 ms , DAO 0 ms
   BSYO 0 ms , TOUT 1000 ms
   INSTR: A0 80
12:24.143: Script execution cancelled.
12:24.153: PC TIMEOUT

I also periodically get read timeouts when reading A0h.

Revelprog IS v1.8.5
Windows 11
Ryzen 3900X, X570 chipset
Various QSFP modules from Avago, Arista, KAIAM and Mellanox

The QSFP board is powered from a 2.1A USB charger. I have tried with the programmer hooked directly to ports on the motherboard that are USB 2.0, 3.0 and 3.1 but the results are always the same. I have only used the USB cables that came with the kit.

I have also noticed that when I try to write a byte the programmer will timeout on operation 2 or 3, but not consistently either one. It seems like a timing issue.

Any suggestions for other things to try?

Posts: 1373
Joined: Wed Mar 25, 2015 8:54 am
Location: Warsaw, Poland
Has thanked: 48 times
Been thanked: 142 times

Re: QSFP Page Select is not working - timeout

Postby ArT » Wed Mar 30, 2022 8:54 am

I checked on some QSFP and page select is working fine. Have you tried maybe on different QSFP? or on different PC? Generally programmer may not work properly on virtual machine or USB HUB due to additional delays.

According to timing issue - I'm sending you on PM small update - there are some fixes for SFP/QSFP which will be implemented in official update in future. Please test it. Details on PM.

You can also try Byte Programming mode (BP flag) - some QSFP may require it. There is dedicated checkbox for it.

Return to “Technical Support”

Who is online

Users browsing this forum: No registered users and 2 guests